Körkörös hivatkozás – így bogozd ki

Gyakran érkezik a kérdés: Van egy Excel táblázatom, ami körkörös hivatkozás hibát ír ki, de nem találom a hibát. Hogyan lehet megtalálni, hogy hol rontottam el a képletezést?

A körkörös hivatkozás akkor jelenik meg, ha egy képlet önmagával számol, vagy egy továbbkalkulált későbbi eredményre hivatkozik.

Például az A9 cellába ez kerül:

=A9+2
=A9+A8
=SZUM(A2:A9)
=SZUM(A2:B20) hiszen az A9 része a tartománynak, bár kiírva nem szerepel.

Ilyen esetekben egy hibaüzenet jelenik meg, amely „körkörös hivatkozás” problémát említ. Az OK gombra kattintva [azaz az Enter billentyű! megnyomásával] bezárható az ablak.

Körkörös hivatkozás hibaüzenet

Ezután a nulla érték jelenik meg a cellában, amit érdemes javítani!

Hogyan javítsd a körkörös hivatkozást?

Mindenképpen tisztázd magadban, hogy melyik cellában állsz (ezt a bal felső sarokban láthatod, illetve a következő pontban láthatod, hogy az Excel hibakereső funkciója is segít.

Ha ugyanezt a hivatkozást látod a szerkesztőlécben, akkor mindenképpen töröld vagy módosítsd. Gondold át, hogy mit szerettél volna kiszámolni, és ennek megfelelően módosítsd a képletet. Ha egyszerűbb, inkább kezdd újra.

Használd az F2 funkciógombot! Így látod, hogy hol csúsztál félre.

Melyik cellában van a körkörös hivatkozás?

Ha utólag kell megkeresni a hibát, akkor is több lehetőség van.

Gyakran bal alul az állapotsoron is látod:

Az állapotsor mutatja a körkörös hivatkozás helyét.

Vagy kattints a Képletek fülre, és nézd meg a Hibaellenörzés pontban:A Képletek fülön is van Hibaellenörzés menü, benne körkörös hivatkozásokkal

Több cellában is körkörös hivatkozás van

Ha több cellában is szerepel körkörös hivatkkozás, akkor az elsőt kijavítva egyből megjelenik a következő hibás cella az állapotsoron vagy a “Körkörös hivatkozás” felirat.

Több munkalap esetén menj végig a füleken (Ctrl PgDn) vagy keresd meg a Képletek fülön a hibás cellákat.

Ha szeretnél személyes segítséget az Excelhez, fordulj hozzánk bizalommal!

Nézd meg ezt is

3 módszer a képleteket ellenőrzésére

7 hasznos Excel trükk, amivel időt nyerhetsz

About Bernadett

Bernadett 10 évig dolgozott a versenyszférában, majd az ott szerzett tapasztalatok alapján állította össze az ExcelTitok képzési módszert. 2010 szeptembere óta csak Excel oktatással foglalkozik. Oktatói csapatával mára már több mint 1000 emberrel foglalkoztak személyesen, egyéni oktatás keretében. Célja, hogy írásainak és munkájának köszönhetően minél többen megbarátkozzanak az Excellel.

Vélemény, hozzászólás?

Az email címet nem tesszük közzé. A kötelező mezőket * karakterrel jelöljük.