Körkörös hivatkozás – így bogozd ki

Gyakran érkezik a kérdés: Van egy Excel táblázatom, ami körkörös hivatkozás hibát ír ki, de nem találom a hibát. Hogyan lehet megtalálni, hogy hol rontottam el a képletezést?

A körkörös hivatkozás akkor jelenik meg, ha egy képlet önmagával számol, vagy egy továbbkalkulált későbbi eredményre hivatkozik.

Például az A9 cellába ez kerül:

=A9+2
=A9+A8
=SZUM(A2:A9)
=SZUM(A2:B20) hiszen az A9 része a tartománynak, bár kiírva nem szerepel.

Ilyen esetekben egy hibaüzenet jelenik meg, amely „körkörös hivatkozás” problémát említ. Az OK gombra kattintva [azaz az Enter billentyű! megnyomásával] bezárható az ablak.

Körkörös hivatkozás hibaüzenet

Ezután a nulla érték jelenik meg a cellában, amit érdemes javítani!

Hogyan javítsd a körkörös hivatkozást?

Mindenképpen tisztázd magadban, hogy melyik cellában állsz (ezt a bal felső sarokban láthatod, illetve a következő pontban láthatod, hogy az Excel hibakereső funkciója is segít.

Ha ugyanezt a hivatkozást látod a szerkesztőlécben, akkor mindenképpen töröld vagy módosítsd. Gondold át, hogy mit szerettél volna kiszámolni, és ennek megfelelően módosítsd a képletet. Ha egyszerűbb, inkább kezdd újra.

Használd az F2 funkciógombot! Így látod, hogy hol csúsztál félre.

Melyik cellában van a körkörös hivatkozás?

Ha utólag kell megkeresni a hibát, akkor is több lehetőség van.

Gyakran bal alul az állapotsoron is látod:

Az állapotsor mutatja a körkörös hivatkozás helyét.

Vagy kattints a Képletek fülre, és nézd meg a Hibaellenörzés pontban:A Képletek fülön is van Hibaellenörzés menü, benne körkörös hivatkozásokkal

Több cellában is körkörös hivatkozás van

Ha több cellában is szerepel körkörös hivatkkozás, akkor az elsőt kijavítva egyből megjelenik a következő hibás cella az állapotsoron vagy a “Körkörös hivatkozás” felirat.

Több munkalap esetén menj végig a füleken (Ctrl PgDn) vagy keresd meg a Képletek fülön a hibás cellákat.

Ha szeretnél személyes segítséget az Excelhez, fordulj hozzánk bizalommal!

Nézd meg ezt is

3 módszer a képleteket ellenőrzésére

7 hasznos Excel trükk, amivel időt nyerhetsz

About Bernadett

Bernadett 10 évig dolgozott a versenyszférában, majd az ott szerzett tapasztalatok alapján állította össze az ExcelTitok képzési módszert. 2010 szeptembere óta csak Excel oktatással foglalkozik. Oktatói csapatával mára már több mint 1000 emberrel foglalkoztak személyesen, egyéni oktatás keretében. Célja, hogy írásainak és munkájának köszönhetően minél többen megbarátkozzanak az Excellel.

Néha elakadsz?

Néha elakadsz, és megnyugtató lenne, ha feltehetnéd a kérdéseid, és segítene valaki? Vagy vágysz arra, hogy egy-egy feladatot átbeszélj egy hozzáértő szakemberrel, hogy megerősítést kapj?

A fejlődés igénye...

Érzed a fejlődés igényét ebben a gyorsuló világban? Szeretnél kihasználni az Excelben rejlő lehetőségeket, és megismerni a munkavégzést gyorsító trükköket?

Támogató közösség...

Szeretnél egy támogató közösség tagja lenni, akik ugyanúgy lelkesednek az Excelért, mint Te?

Végre itt a megoldás! Ilyen még nem volt!

Létrehoztunk egy Titkos VIP Klubot, ahol egész évben fejlődhetsz.

  • Tanulásra: folyamatosan osztjuk meg a leghasznosabb, munkát gyorsító tippjeinket, amelyeket egyből alkalmazhatsz is.
  • Kérdezésre: felteheted a munka során felmerülő kérdéseid, amelyhez gyors útbaigazítást kapsz.
  • Közösségre: egy “haladó” Excel tanuló közösség része lehetsz, amely folyamatosan inspirálni fog. Rendszeresen megvitatunk “ti-ezt-hogy-szoktátok-csinálni” kérdéseket, így működő mintákat, sablonokat is begyűjthetsz. Ezzel együtt nem veszel el a “tömegben” – ugyanúgy odafigyelünk Rád, mintha egyedül jöttél volna tanfolyamra!
  • VIP Facebook csoport tagság, ahol bármikor kérdezhetsz.
  • Hatalmas online Excel gyűjtemény azonnali megoldás konkrét példákkal.
  • 4 szakképzett és nagyon tapasztalt Excel oktató segítsége mind rendelkezésedre áll.
  • Folyamatosan új tippek, megoldások, amik megkönnyítik munkádat.
  • 25% kedvezmény a kijelölt képzésekre, anyagokra.

TOP 3 indok, amiért megéri ma csatlakoznod:

Kérdezési lehetőség

Fejlődési lehetőség

Támogató közösség

Hasznos volt? Oszd meg az ismerőseiddel is!

Share on facebook
Facebook
Share on linkedin
LinkedIn
Share on pinterest
Pinterest
Share on email
Email
Share on tumblr
Tumblr
Share on skype
Skype
Share on whatsapp
WhatsApp

Mi a véleményed? Van kérdésed?

Leave a Comment

Az email címet nem tesszük közzé. A kötelező mezőket * karakterrel jelöltük

Vip Excel Klub

VIP Excel Klub, ha igazán fontos neked, hogy fejlődj a munkádban

Kérdezés

Fejlődés

Közösség

Gyorsítsd a munkád és növeld az eredményeid!

Add meg az adataid, és szerezd meg a leggyakoribb billentyűkombinációk listáját, valamint gyűjts be minél több hasznos Excel tippet az online mini-tanfolyamon!

Kérlek, ezt a mezőt töltsd ki!
Kérjük, ezt a mezőt is legyen szíves kitölteni!

Oszd meg az ismerőseiddel is!

Share on facebook
Facebook
Share on linkedin
LinkedIn
Share on skype
Skype
Share on whatsapp
WhatsApp
Share on email
Email

Kövess minket Facebookon!

Legutóbbi bejegyzések

Ezt olvastad már?

Félreértések a (%) százalékjel körül

A százalékjel használata nem egyértelmű. Maga az átváltás sem: 20% = 0,2 és 100% = 1 A százalékszámítás pedig szinte mindenkinél kritikus terület, holott a hétköznapi …

Tovább olvasom →

Ingyenes Excel tippek: 22 + 3 tipp a táblázat formázásához

Itt a blogon folyamatosan jelennek meg az ingyenes Excel tippek a személyes tapasztalataim (gyakori kérdéseitek) alapján. Most összegyűjtöttem a táblázat formázásához kapcsolódó írásokat: A Szerzőről Legfrissebb …

Tovább olvasom →

Liebster díjat kaptam – Kőrös Bernadett, a blog szerzője más szemmel

Most egy rendhagyó poszt következik, aminek kevesebb köze van az Excelhez, de azért maradj itt velem, mert találsz benne inspiráló tippeket, témákat – és engem …

Tovább olvasom →