HAHIBA – Így cseréld le a #HIÁNYZIK értéket

Gyakori kérdés: “Ha az FKERES függvény nem talál semmit, hogyan lehet megoldani, hogy ne A #HIÁNYZIK hibát írja ki, hanem pl. ‘Nincs adat’, vagy maradjon üres?

Erre megoldás a HAHIBA függvény, mely 2007-től elérhető, vagy a HAHIÁNYZIK függvény, amely a 2013-as verzótól létezik

Az ebben a cikkben szereplő linkek ugyanebben az ablakban nyílnak meg. Ha szeretnéd inkább külön ablakban megnyitni, akkor a Ctrl nyomva tartása közben kattints a linkre.

#HIÁNYZIK hibaérték

Azt kell értened, hogy a hibaüzenetek speciális értékek, és nem szövegek. Tehát ha Te beírod egy cellába, hogy #HIÁNYZIK, az nem ugyanaz, mint amikor az FKERES függvény eredménye lesz #HIÁNYZIK. Éppen ezért egy egyszerű logikai vizsgálat (pl. B2=”#HIÁNYZIK”) sem működik.

HIBA.E, HIBÁS függvények

Korábban már léteztek függvények, amelyek megvizsgálták a képletről, hogy az valódi eredményt, vagy hibaértéket adott ki. Ez Igen/Nem (Igaz/Hamis) választ adott, ezért általában HA függvénnyel együtt alkalmazták.

Ebben azonban ismételni kellett a számítást: Ha a számítás eredménye hiba, akkor írja ki, hogy “Javítani” (vagy maradjon üres), különben legyen az eredeti számítás:

=HA(HIBÁS(A2/B2); "Javítani"; A2/B2)

Amennyiben hiba esetén üres cellát szeretnél kapni, akkor semmit ne írj az idézőjelek közé:

=HA(HIBÁS(A2/B2); “”; A2/B2)

HIBÁS függvény

Valamennyi hibaértékre (#SZÁM, #ÉRTÉK!, #HIV!, #ZÉRÓOSZTÓ!, #NÉV?, #NULLA! és #HIÁNYZIK) meg tudja állapítani, hogy hibaérték.

HIBA.E függvény

Az érték a #HIÁNYZIK esetében HAMIS, míg a többi hibaérték esetén IGAZ eredményt ad. Tehát FKERES esetén nem használható.

FKERES függvénynél már a függvény eredményéről kell dönteni, hogy hiba vagy találat lett-e. Így elég bonyolult lesz a képlet:
=HA(HIBÁS(FKERES(K2;A:C;2;0)); “Javítani”; FKERES(K2;A:C;2;0))

HAHIBA, HAHIÁNYZIK függvények

Az egyszerűsítés jegyében született meg a HAHIBA függvény: csak a számítást kell megadni, majd azt az értéket, amire hiba esetén a hibát cserélni szeretnéd:

=HAHIBA(érték; érték_ha_hiba)

Valamennyi hibaértékre (#SZÁM, #ÉRTÉK!, #HIV!, #ZÉRÓOSZTÓ!, #NÉV?, #NULLA! és #HIÁNYZIK) használható.

A függvény mindkét tagját kötelező megadni. Pl.:

=HAHIBA(FKERES(K2;A:C;2;0);"")

A HAHIÁNYZIK függvény felépítése megegyezik a HAHIBA függvénnyel. Viszont csakis a #HIÁNYZIK hibát cseréli le, pl.:

=HAHIÁNYZIK(FKERES(K2;A:C;2;0);"")

Azaz FKERES és egyéb keresőfüggvények esetén a HAHIBA és a HAHIÁNYZIK függvény is használható.

Tanulj velünk Excelt!

Ha a munkád miatt szeretnéd még gyorsabban és ügyesebben használni az Excel táblázatokat, vagy csak jobban érteni az összefüggéseket, akkor a következő lehetőségeket ajánlom:

  • Excel Tankönyv: Kezdőtől a haladó szintig megismerheted az Excelben rejlő lehetőségeket. Ha szeretsz könyvből tanulni, akkor ez egy jó lehetőség, hogy egy általános képed legyen az Excel funkcióiról.
  • ExcelTitok VIP Klub: egy hely, ahol a saját tempódban tanulhatsz, és bármikor felteheted a kérdéseidet.
  • Személyre szabott, egyéni Excel tanfolyamok: profi tanárainkkal szívesen segítünk, hogy megértsd és begyakorold az Excel különböző funkcióit.

About Bernadett

Bernadett 10 évig dolgozott a versenyszférában, majd az ott szerzett tapasztalatok alapján állította össze az ExcelTitok képzési módszert. 2010 szeptembere óta csak Excel oktatással foglalkozik. Oktatói csapatával mára már több mint 2000 emberrel foglalkoztak személyesen, egyéni oktatás keretében. Célja, hogy írásainak és munkájának köszönhetően minél többen megbarátkozzanak az Excellel.

Excel Titok VIp Klub

Gyorsabb, eredményesebb munkavégzés.

Napi szinten használod az Excelt, és szeretnél a problémákon gyorsan átlendülni? Legyél profibb a munkádban és érd el a célod!

Könyv áráért Excel könyvtár

Jelenleg a klubban rengeteg azonnal használható gyakorlatias tipp van. Nem kell órákig keresned a megoldást Itt megtalálod, ami kell a munkádhoz.

Folyamatosan fejlődsz míg eléred a célod!

Előléptetés, nagyobb megbecsülés vagy több szabadidő? Ezt fogod elérni, mert ha elakadsz a Klubban kérdezhetsz és tanulhatsz.

Szakértőktől kérdezhetsz akár minden nap

Szeretnél egy támogató közösség tagja lenni, akik ugyanúgy lelkesednek az Excelért, mint Te?

Hasznos volt? Oszd meg az ismerőseiddel is!

Megosztás itt: facebook
Facebook
Megosztás itt: linkedin
LinkedIn
Megosztás itt: pinterest
Pinterest
Megosztás itt: email
Email
Megosztás itt: tumblr
Tumblr
Megosztás itt: skype
Skype
Megosztás itt: whatsapp
WhatsApp

Mi a véleményed? Van kérdésed?

Leave a Comment

Az email címet nem tesszük közzé. A kötelező mezőket * karakterrel jelöltük

Gyorsítsd a munkád és növeld az eredményeid!

Add meg az adataid, és szerezd meg a leggyakoribb billentyűkombinációk listáját, valamint gyűjts be minél több hasznos Excel tippet az online mini-tanfolyamon!

Kérlek, ezt a mezőt töltsd ki!
Kérjük, ezt a mezőt is legyen szíves kitölteni!

Excel Titok VIp Klub

Gyorsabb, eredményesebb munkavégzés. Magasabb fizetés és több szabadidő!

Napi szinten használod az Excelt, és szeretnél a problémákon gyorsan átlendülni? Legyél profibb a munkádban és érd el a célod!

Folyamatosan fejlődsz míg eléred a célod!

Könyv áráért Excel könyvtár

Szakértőktől kérdezhetsz akár minden nap

Oszd meg az ismerőseiddel is!

Megosztás itt: facebook
Facebook
Megosztás itt: linkedin
LinkedIn
Megosztás itt: skype
Skype
Megosztás itt: whatsapp
WhatsApp
Megosztás itt: email
Email

Kövess minket Facebookon!

Legutóbbi bejegyzések

Ezt olvastad már?

5 tipp, hogy mire használd az Excelt

Ha azt mondom, hogy Excel táblázat, a legtöbb embernek a munkahelye jut az eszébe, ahol napi szinten szokta használni a táblázatkezelő programot. Pedig a hétköznapokon …

Tovább olvasom →

Felismered George Clooneyt és a többi hírességet?

A képek alkotója az ausztrál Guy Whitby (művésznevén WorkByKnight, azaz WBK), aki többek között a számítógép billentyűiből készít mozaikszerű képeket. A Szerzőről Legfrissebb írásai About …

Tovább olvasom →

Gyorsabb képletezés: itt is használj billentyűzetet!

Mennyivel lennél gyorsabb, ha számolás közben elfelejtenéd az egeret? Talán észre sem veszed, hogy milyen gyakran használod feleslegesen. Gyakorold a képletírást egér nélkül! Ugyanis így a gyorsabb képletezés …

Tovább olvasom →