Nem egyenlő jel az Excelben

Összehasonlításnál szükséged lehet a “nem egyenlő jel”-re. Például, amikor egy cella tartalmánál ki akarsz zárni valamit. Ha a vidéki ügyfeleket keresed: lehetetlenség felsorolni az összes várost, helyette egyszerűbb azt mondani, hogy nem (egyenlő) Budapest.

Az összehasonlítás a logikai műveleteket jelenti, ahol logikai operátorokat (jeleket) használunk: <, >, = jeleket. Vagyis csak ezeket kombinálhatod a “nem egyenlő” meghatározásához is.

Így az Excelben a <>, azaz az egymás felé fordított kacsacsőrök lesznek a nem egyenlő jel.

A logikai művelet eredménye mindig IGAZ vagy HAMIS. Ezt önmagában is használhatod, vagy HA függvényt és egyéni feltételes formázást is építhetsz rá.

Nem egyenlő jel az Excelben

<> jelentése

Tehát a <> (kisebb-nagyobb) jelentése az Excelben: nem egyenlő. Ha ezt látod a szerkesztőlécen, az mindig azt jelenti, hogy a megadott cella tartalma ne legyen az utána következő érték.

Az = (egyenlő) és <> (nem egyenlő) összehasonlítás jellemzően szöveges tartalmakra használjuk, így az utána megadott szöveget idézőjelek közé kell írni. De természetesen cellából is veheted az értéket. Ha fix cellára hivatkozol, akkor ne felejtsd el dollározni.

Példa a nem egyenlő jel használatára

Egymás mellett szerepel a C és D oszlopban a partnertől kapott árlista és a saját nyilvántartásunk értéke. (Korábban egy FKERES függvénnyel összeollóztuk az adatokat.)

Ha nem egyezik a 2 érték, írjuk ki a cellába, hogy “ellenőrizni”, különben pedig legyen üres:

=HA(C2<>D2;”ellenőrizni”;””)

Persze egy ilyen egyszerű állítást egyszerűbb fordítva megfogalmazni: =HA(C2=D2;””;”ellenőrizni”)

Viszont ha a Feltételes formázással akarod színezni a hibás értékeket, akkor ott már van jelentősége az állításnak. A Feltételes formázás ugyanis mindig az IGAZ értékeket színezi, így ott mindenképpen ezt a képletet add meg, ha az ellenőrizendő sorokat szeretnéd színesre: =C2<>D2

Példa a “vidék” használatára

Ha a B oszlopban szereplnek a városok, és a vidéki városokat keresed köztük, akkor a feltétel:

B2<>”Budapest”

Ha függvénybe ágyazva: =HA(B2<>”Budapest”;”vidék”;”Budapest”)

Természetesen itt is egyszerűbb fordítva: =HA(B2=”Budapest”;”Budapest”;”vidék”)

Viszont egy többszörösen összetett állításnál már szükség lehet a nem egyenlő kritériumra.

Például külön csoportként kezeljük azokat a vidéki vevőket, akik 100.000 Ft-nál többet költöttek. Tehát egyszerre 2 feltételnek kell teljesülnie, amihez az ÉS függvényre lesz szükség. Az elköltött összeget a C oszlopból veszem – a kategóriák tetszés szerint átírhatóak:

=HA(ÉS(B2<>”Budapest”;C2>=100000);”vidéki nagy”;”egyéb”)

Ha a fennmaradó ügyfeleket további 2 csoportra osztjuk: 50.000 Ft felett és alatt – akkor ahhoz egy második HA függvény is szükséges lesz:

=HA(ÉS(B2<>”Budapest”;C2>=100000);”vidéki nagy”;HA(C2>=50000;”nagy”;”kicsi”))

Nem üres feltétel megadása

Mivel a szövegeket idézőjel közé tesszük, az üres cellát az idézőjel közötti semmi jelenti: “”

Így B2=”” vizsgálja azt, hogy B2 üres, míg B2<>””, azt jelenti, hogy a B2 cella nem üres, azaz szerepel benne valamilyen érték.

Ezt a feltételt olyankor használhatod, ha például a képletet addig el szeretnéd rejteni, amíg nincs kitöltve pl a B oszlop:

=HA(B2=””;””;B2*$K$1) vagy =HA(B2<>””;B2*$K$1;””)

Ez is érdekelhet

Excel képletek egér nélkül

3 módszer a képleteket ellenőrzésére

Szeretnél többet tudni az Excelről?

Ha szorgalmas vagy és szeretsz könyvből tanulni, szeretnél hasznos tippeket, billentyűkombinációkat és függvényeket tanulni, akkor rendeld meg az Excel Kezdő & Haladó tankönyvünket.

Ha szeretnéd rendszerezetten átnézni az Excel alapjait, és szeretsz másokkal együtt tanulni, akkor gyere az online csoportos Excel képzésünkre! Ha egyénileg szeretnél tanulni vagy a munkáddal kapcsolatos táblázatokat rendbe tenni, akkor várunk egyéni Excel oktatásra.

Vagy gyere a VIP Klubba, ahol hasonló érdekes megoldásokat találsz, és Te is bármikor kérdezhetsz – így egy biztos háttérrel a saját tempódban haladhatsz: Excel VIP Klub.

About Bernadett

Bernadett 10 évig dolgozott a versenyszférában, majd az ott szerzett tapasztalatok alapján állította össze az ExcelTitok képzési módszert. 2010 szeptembere óta csak Excel oktatással foglalkozik. Oktatói csapatával mára már több mint 2000 emberrel foglalkoztak személyesen, egyéni oktatás keretében. Célja, hogy írásainak és munkájának köszönhetően minél többen megbarátkozzanak az Excellel.

Excel Titok VIp Klub

Gyorsabb, eredményesebb munkavégzés.

Napi szinten használod az Excelt, és szeretnél a problémákon gyorsan átlendülni? Legyél profibb a munkádban és érd el a célod!

Könyv áráért Excel könyvtár

Jelenleg a klubban rengeteg azonnal használható gyakorlatias tipp van. Nem kell órákig keresned a megoldást Itt megtalálod, ami kell a munkádhoz.

Folyamatosan fejlődsz míg eléred a célod!

Előléptetés, nagyobb megbecsülés vagy több szabadidő? Ezt fogod elérni, mert ha elakadsz a Klubban kérdezhetsz és tanulhatsz.

Szakértőktől kérdezhetsz akár minden nap

Szeretnél egy támogató közösség tagja lenni, akik ugyanúgy lelkesednek az Excelért, mint Te?

Hasznos volt? Oszd meg az ismerőseiddel is!

Megosztás itt: facebook
Facebook
Megosztás itt: linkedin
LinkedIn
Megosztás itt: pinterest
Pinterest
Megosztás itt: email
Email
Megosztás itt: tumblr
Tumblr
Megosztás itt: skype
Skype
Megosztás itt: whatsapp
WhatsApp

Mi a véleményed? Van kérdésed?

Leave a Comment

Az e-mail-címet nem tesszük közzé.

Gyorsítsd a munkád és növeld az eredményeid!

Add meg az adataid, és szerezd meg a leggyakoribb billentyűkombinációk listáját, valamint gyűjts be minél több hasznos Excel tippet az online mini-tanfolyamon!

Kérlek, ezt a mezőt töltsd ki!
Kérjük, ezt a mezőt is legyen szíves kitölteni!

Excel Titok VIp Klub

Gyorsabb, eredményesebb munkavégzés. Magasabb fizetés és több szabadidő!

Napi szinten használod az Excelt, és szeretnél a problémákon gyorsan átlendülni? Legyél profibb a munkádban és érd el a célod!

Folyamatosan fejlődsz míg eléred a célod!

Könyv áráért Excel könyvtár

Szakértőktől kérdezhetsz akár minden nap

Oszd meg az ismerőseiddel is!

Megosztás itt: facebook
Facebook
Megosztás itt: linkedin
LinkedIn
Megosztás itt: skype
Skype
Megosztás itt: whatsapp
WhatsApp
Megosztás itt: email
Email

Kövess minket Facebookon!

Legutóbbi bejegyzések

Ezt olvastad már?

Életmentő tippek állásinterjú előtt

Az állásinterjú mindenki számára egy stresszes helyzetet jelent, különösen, ha még egy Excel-tesztre is kilátás van. Hiszen nagy a tét, nagy az izgalom és az …

Tovább olvasom →

3 duplakattos trükk a gyorsabb munkáért

A blogon is, és az oktatás során is kiemelt figyelmet szentelek a gyorsbillentyűknek, mert jól tudom, hogy napi fél-egy órát (azaz évente 3-10 teljes napot) …

Tovább olvasom →

A szép táblázat 7 tulajdonsága

Mire figyelj összesítő táblázat készítéskor és formázáskor? Ha betartod ezt a 7 pontot, mindig szép táblázat kerül ki a kezeidből, és biztosan megdicsér a főnök, ráadásul …

Tovább olvasom →